re = />[\s]*([[:digit:]]+(\.[[:digit:]]+)?)[\s]*<\//
str = '<td class="text-right"
onmouseenter="$(this).find(\'.overlay-viewable-box:first\').show();"
onmouseleave="$(this).find(\'.overlay-viewable-box:first\').hide();">
2.004
</td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end