# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?<pad>\A[^"]*"[^"]*?|\G[^"{}]*|\G"[^"]*")(((?<start>\{%)-(?<content>[^"]*?)-(?<end>%\}))|(?<pad2>[^"{}%]*)))/${pad}${pad2}${start}${content}${end}/gm;t' <<< "<span foo=\"bar\" class=\"{%- if foo == true -%} blue{%- else -%} red{%- endif -%}\">item {%- DONT TOUCH THIS - IT IS NOT IN QUOTES -%} </span> \"rs gs{%- Replace this, it is in quotes -%} afeafe\""