#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?<pad>\A[^"]*"[^"]*?|\G[^"{}]*|\G"[^"]*")(((?<start>\{%)-(?<content>[^"]*?)-(?<end>%\}))|(?<pad2>[^"{}%]*)))"
Local $sString = "<span foo="bar" class="{%- if foo == true -%} blue{%- else -%} red{%- endif -%}">item {%- DONT TOUCH THIS - IT IS NOT IN QUOTES -%} </span> "rs gs{%- Replace this, it is in quotes -%} afeafe""
Local $sSubst = "${pad}${pad2}${start}${content}${end}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)