using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<pad>\A[^""]*""[^""]*?|\G[^""{}]*|\G""[^""]*"")(((?<start>\{%)-(?<content>[^""]*?)-(?<end>%\}))|(?<pad2>[^""{}%]*)))";
string substitution = @"${pad}${pad2}${start}${content}${end}";
string input = @"<span foo=""bar"" class=""{%- if foo == true -%} blue{%- else -%} red{%- endif -%}"">item {%- DONT TOUCH THIS - IT IS NOT IN QUOTES -%} </span> ""rs gs{%- Replace this, it is in quotes -%} afeafe""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}