# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?<pad>\A[^\"]*\"[^\"]*?|\G[^\"{}]*|\G\"[^\"]*\")(((?<start>\{%)-(?<content>[^\"]*?)-(?<end>%\}))|(?<pad2>[^\"{}%]*)))"
test_str = "<span foo=\"bar\" class=\"{%- if foo == true -%} blue{%- else -%} red{%- endif -%}\">item {%- DONT TOUCH THIS - IT IS NOT IN QUOTES -%} </span> \"rs gs{%- Replace this, it is in quotes -%} afeafe\""
subst = "${pad}${pad2}${start}${content}${end}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.