import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<pad>\\A[^\"]*\"[^\"]*?|\\G[^\"\\{\\}]*|\\G\"[^\"]*\")(((?<start>\\{%)-(?<content>[^\"]*?)-(?<end>%\\}))|(?<pad2>[^\"\\{\\}%]*)))";
final String string = "<span foo=\"bar\" class=\"{%- if foo == true -%} blue{%- else -%} red{%- endif -%}\">item {%- DONT TOUCH THIS - IT IS NOT IN QUOTES -%} </span> \"rs gs{%- Replace this, it is in quotes -%} afeafe\"";
final String subst = "${pad}${pad2}${start}${content}${end}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}