use strict;
my $str = '<span foo="bar" class="{%- if foo == true -%} blue{%- else -%} red{%- endif -%}">item {%- DONT TOUCH THIS - IT IS NOT IN QUOTES -%} </span> "rs gs{%- Replace this, it is in quotes -%} afeafe"';
my $regex = qr/((?<pad>\A[^"]*"[^"]*?|\G[^"{}]*|\G"[^"]*")(((?<start>\{%)-(?<content>[^"]*?)-(?<end>%\}))|(?<pad2>[^"{}%]*)))/mp;
my $subst = '${pad}${pad2}${start}${content}${end}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";