$re = '/((?<pad>\A[^"]*"[^"]*?|\G[^"{}]*|\G"[^"]*")(((?<start>\{%)-(?<content>[^"]*?)-(?<end>%\}))|(?<pad2>[^"{}%]*)))/m';
$str = '<span foo="bar" class="{%- if foo == true -%} blue{%- else -%} red{%- endif -%}">item {%- DONT TOUCH THIS - IT IS NOT IN QUOTES -%} </span> "rs gs{%- Replace this, it is in quotes -%} afeafe"';
$subst = "${pad}${pad2}${start}${content}${end}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;