re = /((?<pad>\A[^"]*"[^"]*?|\G[^"{}]*|\G"[^"]*")(((?<start>\{%)-(?<content>[^"]*?)-(?<end>%\}))|(?<pad2>[^"{}%]*)))/m
str = '<span foo="bar" class="{%- if foo == true -%} blue{%- else -%} red{%- endif -%}">item {%- DONT TOUCH THIS - IT IS NOT IN QUOTES -%} </span> "rs gs{%- Replace this, it is in quotes -%} afeafe"'
subst = '${pad}${pad2}${start}${content}${end}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result