# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(@[a-zA-Zа-яА-Я0-9]+?)#(\d+)/<a href="\/user\/$2" class="user-tag">$1<\/a>/g;t' <<< "Привет @marvela#115! Как дела? Забань плиз @du123r2ov#322 пока не поздно. не может
просто выебал @wtfабдул#322 и @Алексея#322
@Октейн#228"