using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(@[a-zA-Zа-яА-Я0-9]+?)#(\d+)";
string substitution = @"<a href=""/user/$2"" class=""user-tag"">$1</a>";
string input = @"Привет @marvela#115! Как дела? Забань плиз @du123r2ov#322 пока не поздно. не может
просто выебал @wtfабдул#322 и @Алексея#322
@Октейн#228";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}