import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(@[a-zA-Zа-яА-Я0-9]+?)#(\\d+)";
final String string = "Привет @marvela#115! Как дела? Забань плиз @du123r2ov#322 пока не поздно. не может\n"
+ "просто выебал @wtfабдул#322 и @Алексея#322\n"
+ "@Октейн#228";
final String subst = "<a href=\"/user/$2\" class=\"user-tag\">$1</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}