package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(@[a-zA-Zа-яА-Я0-9]+?)#(\d+)`)
var str = `Привет @marvela#115! Как дела? Забань плиз @du123r2ov#322 пока не поздно. не может
просто выебал @wtfабдул#322 и @Алексея#322
@Октейн#228`
var substitution = "<a href="/user/$2" class="user-tag">$1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}