// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(@[a-zA-Zа-яА-Я0-9]+?)#(\d+)").unwrap();
let string = "Привет @marvela#115! Как дела? Забань плиз @du123r2ov#322 пока не поздно. не может
просто выебал @wtfабдул#322 и @Алексея#322
@Октейн#228";
let substitution = "<a href=\"/user/$2\" class=\"user-tag\">$1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}