import Foundation
let pattern = ##"(@[a-zA-Zа-яА-Я0-9]+?)#(\d+)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
Привет @marvela#115! Как дела? Забань плиз @du123r2ov#322 пока не поздно. не может
просто выебал @wtfабдул#322 и @Алексея#322
@Октейн#228
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="/user/$2" class="user-tag">$1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)