$re = '/(@[a-zA-Zа-яА-Я0-9]+?)#(\d+)/';
$str = 'Привет @marvela#115! Как дела? Забань плиз @du123r2ov#322 пока не поздно. не может
просто выебал @wtfабдул#322 и @Алексея#322
@Октейн#228';
$subst = "<a href=\"/user/$2\" class=\"user-tag\">$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;