use strict;
my $str = 'Привет @marvela#115! Как дела? Забань плиз @du123r2ov#322 пока не поздно. не может
просто выебал @wtfабдул#322 и @Алексея#322
@Октейн#228';
my $regex = qr/(@[a-zA-Zа-яА-Я0-9]+?)#(\d+)/p;
my $subst = '<a href="/user/$2" class="user-tag">$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";