#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\\\\([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})\\[-a-zA-Z_ 0-9]+\\)(?:[-a-zA-Z_ 0-9\.]+\\)*"
Local $sString = "\\192.168.0.250\Volume1_public\21 - THW Test Rig\Automation\Results\05 - 717 Official Rig\7 - Nitya\717 - Realistic Test v0.1 For SC v2.02.00 onwards Isolated CopyLogs Test.txt\13012023_8\"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")