const regex = /(\\\\([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})\\[-a-zA-Z_ 0-9]+\\)(?:[-a-zA-Z_ 0-9\.]+\\)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\\\\\\([0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3})\\\\[-a-zA-Z_ 0-9]+\\\\)(?:[-a-zA-Z_ 0-9\\.]+\\\\)*', 'gm')
const str = `\\\\192.168.0.250\\Volume1_public\\21 - THW Test Rig\\Automation\\Results\\05 - 717 Official Rig\\7 - Nitya\\717 - Realistic Test v0.1 For SC v2.02.00 onwards Isolated CopyLogs Test.txt\\13012023_8\\`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}