package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\\\\([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})\\[-a-zA-Z_ 0-9]+\\)(?:[-a-zA-Z_ 0-9\.]+\\)*`)
var str = `\\192.168.0.250\Volume1_public\21 - THW Test Rig\Automation\Results\05 - 717 Official Rig\7 - Nitya\717 - Realistic Test v0.1 For SC v2.02.00 onwards Isolated CopyLogs Test.txt\13012023_8\`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}