// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\\\\([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})\\[-a-zA-Z_ 0-9]+\\)(?:[-a-zA-Z_ 0-9\.]+\\)*").unwrap();
let string = "\\\\192.168.0.250\\Volume1_public\\21 - THW Test Rig\\Automation\\Results\\05 - 717 Official Rig\\7 - Nitya\\717 - Realistic Test v0.1 For SC v2.02.00 onwards Isolated CopyLogs Test.txt\\13012023_8\\";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}