using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\\\([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})\\[-a-zA-Z_ 0-9]+\\)(?:[-a-zA-Z_ 0-9\.]+\\)*";
string input = @"\\192.168.0.250\Volume1_public\21 - THW Test Rig\Automation\Results\05 - 717 Official Rig\7 - Nitya\717 - Realistic Test v0.1 For SC v2.02.00 onwards Isolated CopyLogs Test.txt\13012023_8\";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}