use strict;
my $str = '\\\\192.168.0.250\\Volume1_public\\21 - THW Test Rig\\Automation\\Results\\05 - 717 Official Rig\\7 - Nitya\\717 - Realistic Test v0.1 For SC v2.02.00 onwards Isolated CopyLogs Test.txt\\13012023_8\\';
my $regex = qr/(\\\\([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})\\[-a-zA-Z_ 0-9]+\\)(?:[-a-zA-Z_ 0-9\.]+\\)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}