import Foundation
let pattern = #"(\\\\([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})\\[-a-zA-Z_ 0-9]+\\)(?:[-a-zA-Z_ 0-9\.]+\\)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"\\192.168.0.250\Volume1_public\21 - THW Test Rig\Automation\Results\05 - 717 Official Rig\7 - Nitya\717 - Realistic Test v0.1 For SC v2.02.00 onwards Isolated CopyLogs Test.txt\13012023_8\"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)