using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(090|080|070)-\d{4}-\d{4}$";
string input = @"===============
Match
===============
090-1234-5678
080-1234-5678
070-1234-5678
090-9999-9999
090-0000-0000
===============
Not match
===============
060-1234-5678
090-A234-5678
090-1234-567
090-123-5678
09012345678
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}