import Foundation
let pattern = #"^(090|080|070)-\d{4}-\d{4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
===============
Match
===============
090-1234-5678
080-1234-5678
070-1234-5678
090-9999-9999
090-0000-0000
===============
Not match
===============
060-1234-5678
090-A234-5678
090-1234-567
090-123-5678
09012345678
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)