const regex = /^(090|080|070)-\d{4}-\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(090|080|070)-\\d{4}-\\d{4}$', 'gm')
const str = `===============
Match
===============
090-1234-5678
080-1234-5678
070-1234-5678
090-9999-9999
090-0000-0000
===============
Not match
===============
060-1234-5678
090-A234-5678
090-1234-567
090-123-5678
09012345678
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}