// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(090|080|070)-\d{4}-\d{4}$").unwrap();
let string = "===============
Match
===============
090-1234-5678
080-1234-5678
070-1234-5678
090-9999-9999
090-0000-0000
===============
Not match
===============
060-1234-5678
090-A234-5678
090-1234-567
090-123-5678
09012345678
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}