import re
regex = re.compile(r"^(090|080|070)-\d{4}-\d{4}$", flags=re.MULTILINE)
test_str = ("===============\n"
" Match\n"
"===============\n"
"090-1234-5678\n"
"080-1234-5678\n"
"070-1234-5678\n"
"090-9999-9999\n"
"090-0000-0000\n\n"
"===============\n"
" Not match\n"
"===============\n"
"060-1234-5678\n"
"090-A234-5678\n"
"090-1234-567\n"
"090-123-5678\n"
"09012345678\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")