# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/A(.*?)A(.*?)A/B$1C$2D/gms;t' <<< "text A text A text A text A text A text A text A text A text A text A text "