using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"A(.*?)A(.*?)A";
string substitution = @"B$1C$2D";
string input = @"text A text A text A text A text A text A text A text A text A text A text ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}