package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)A(.*?)A(.*?)A`)
var str = `text A text A text A text A text A text A text A text A text A text A text `
var substitution = "B$1C$2D"
fmt.Println(re.ReplaceAllString(str, substitution))
}