const regex = /A(.*?)A(.*?)A/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('A(.*?)A(.*?)A', 'gms')
const str = `text A text A text A text A text A text A text A text A text A text A text `;
const subst = `B$1C$2D`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);