$re = '/A(.*?)A(.*?)A/ms';
$str = 'text A text A text A text A text A text A text A text A text A text A text ';
$subst = "B$1C$2D";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;