import Foundation
let pattern = #"A(.*?)A(.*?)A"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"text A text A text A text A text A text A text A text A text A text A text "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"B$1C$2D"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)