// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)A(.*?)A(.*?)A").unwrap();
let string = "text A text A text A text A text A text A text A text A text A text A text ";
let substitution = "B$1C$2D";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}