#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)A(.*?)A(.*?)A"
Local $sString = "text A text A text A text A text A text A text A text A text A text A text "
Local $sSubst = "B$1C$2D"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)