import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s*href=\"([^\"]*)\"[^>]*>(.*)<\\/a>";
final String string = "<a href=\"http://www.kimoco.it/prodotti/mazzette/\" title=\"Mazzette colori\"><img src=\"http://www.kimoco.it/wp-content/uploads/2013/06/ico-mazzette-colori.png\" alt=\"mazzetta colori\" width=\"125\" height=\"92\" /></a>\n"
+ "<a href=\"\" title=\"Mazzette colori\">CIAO</a>\n"
+ "<a href=\"mailto:<U+2028>info@kimoco.it\"><U+2028>info@kimoco.it</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}