// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a\s*href="([^"]*)"[^>]*>(.*)<\/a>"#).unwrap();
let string = "<a href=\"http://www.kimoco.it/prodotti/mazzette/\" title=\"Mazzette colori\"><img src=\"http://www.kimoco.it/wp-content/uploads/2013/06/ico-mazzette-colori.png\" alt=\"mazzetta colori\" width=\"125\" height=\"92\" /></a>
<a href=\"\" title=\"Mazzette colori\">CIAO</a>
<a href=\"mailto:<U+2028>info@kimoco.it\"><U+2028>info@kimoco.it</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}