const regex = /<a\s*href="([^"]*)"[^>]*>(.*)<\/a>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a\\s*href="([^"]*)"[^>]*>(.*)<\\\/a>', 'g')
const str = `<a href="http://www.kimoco.it/prodotti/mazzette/" title="Mazzette colori"><img src="http://www.kimoco.it/wp-content/uploads/2013/06/ico-mazzette-colori.png" alt="mazzetta colori" width="125" height="92" /></a>
<a href="" title="Mazzette colori">CIAO</a>
<a href="mailto:<U+2028>info@kimoco.it"><U+2028>info@kimoco.it</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}