re = /<a\s*href="([^"]*)"[^>]*>(.*)<\/a>/
str = '<a href="http://www.kimoco.it/prodotti/mazzette/" title="Mazzette colori"><img src="http://www.kimoco.it/wp-content/uploads/2013/06/ico-mazzette-colori.png" alt="mazzetta colori" width="125" height="92" /></a>
<a href="" title="Mazzette colori">CIAO</a>
<a href="mailto:<U+2028>info@kimoco.it"><U+2028>info@kimoco.it</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end