import re
regex = re.compile(r"<a\s*href=\"([^\"]*)\"[^>]*>(.*)<\/a>")
test_str = ("<a href=\"http://www.kimoco.it/prodotti/mazzette/\" title=\"Mazzette colori\"><img src=\"http://www.kimoco.it/wp-content/uploads/2013/06/ico-mazzette-colori.png\" alt=\"mazzetta colori\" width=\"125\" height=\"92\" /></a>\n"
"<a href=\"\" title=\"Mazzette colori\">CIAO</a>\n"
"<a href=\"mailto:<U+2028>info@kimoco.it\"><U+2028>info@kimoco.it</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")