#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<Button[^>]*[\n\s]+className[^>]*>"
Local $sString = "<Button className={style.red} />" & @CRLF & _
"" & @CRLF & _
"<Button className={style.red}> </Button>" & @CRLF & _
"" & @CRLF & _
"<Button" & @CRLF & _
" palette="primary" " & @CRLF & _
" className={style.blue} " & @CRLF & _
"/>" & @CRLF & _
"" & @CRLF & _
"<Button" & @CRLF & _
" palette="primary"" & @CRLF & _
"/>" & @CRLF & _
"" & @CRLF & _
"<Button" & @CRLF & _
" palette="primary" " & @CRLF & _
" className={style.blue} " & @CRLF & _
">" & @CRLF & _
"</Button>" & @CRLF & _
"" & @CRLF & _
"<Button" & @CRLF & _
" palette="primary" " & @CRLF & _
" condition={ value => 5 ? props1 : props2 }" & @CRLF & _
" className={style.blue} " & @CRLF & _
"/>" & @CRLF & _
"" & @CRLF & _
"<Button" & @CRLF & _
" palette="primary" " & @CRLF & _
" condition={ value <= 5 ? props1 : props2 }" & @CRLF & _
" className={style.blue} " & @CRLF & _
"/>" & @CRLF & _
"" & @CRLF & _
"<Button" & @CRLF & _
" palette="primary" " & @CRLF & _
" className={style.blue} " & @CRLF & _
" condition={ value => 5 ? props1 : props2 }" & @CRLF & _
"/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")