using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<Button[^>]*[\n\s]+className[^>]*>";
string input = @"<Button className={style.red} />
<Button className={style.red}> </Button>
<Button
palette=""primary""
className={style.blue}
/>
<Button
palette=""primary""
/>
<Button
palette=""primary""
className={style.blue}
>
</Button>
<Button
palette=""primary""
condition={ value => 5 ? props1 : props2 }
className={style.blue}
/>
<Button
palette=""primary""
condition={ value <= 5 ? props1 : props2 }
className={style.blue}
/>
<Button
palette=""primary""
className={style.blue}
condition={ value => 5 ? props1 : props2 }
/>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}