import re
regex = re.compile(r"<Button[^>]*[\n\s]+className[^>]*>", flags=re.MULTILINE)
test_str = ("<Button className={style.red} />\n\n"
"<Button className={style.red}> </Button>\n\n"
"<Button\n"
" palette=\"primary\" \n"
" className={style.blue} \n"
"/>\n\n"
"<Button\n"
" palette=\"primary\"\n"
"/>\n\n"
"<Button\n"
" palette=\"primary\" \n"
" className={style.blue} \n"
">\n"
"</Button>\n\n"
"<Button\n"
" palette=\"primary\" \n"
" condition={ value => 5 ? props1 : props2 }\n"
" className={style.blue} \n"
"/>\n\n"
"<Button\n"
" palette=\"primary\" \n"
" condition={ value <= 5 ? props1 : props2 }\n"
" className={style.blue} \n"
"/>\n\n"
"<Button\n"
" palette=\"primary\" \n"
" className={style.blue} \n"
" condition={ value => 5 ? props1 : props2 }\n"
"/>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")