use strict;
my $str = '<Button className={style.red} />
<Button className={style.red}> </Button>
<Button
palette="primary"
className={style.blue}
/>
<Button
palette="primary"
/>
<Button
palette="primary"
className={style.blue}
>
</Button>
<Button
palette="primary"
condition={ value => 5 ? props1 : props2 }
className={style.blue}
/>
<Button
palette="primary"
condition={ value <= 5 ? props1 : props2 }
className={style.blue}
/>
<Button
palette="primary"
className={style.blue}
condition={ value => 5 ? props1 : props2 }
/>';
my $regex = qr/<Button[^>]*[\n\s]+className[^>]*>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}