import Foundation
let pattern = #"<Button[^>]*[\n\s]+className[^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<Button className={style.red} />
<Button className={style.red}> </Button>
<Button
palette="primary"
className={style.blue}
/>
<Button
palette="primary"
/>
<Button
palette="primary"
className={style.blue}
>
</Button>
<Button
palette="primary"
condition={ value => 5 ? props1 : props2 }
className={style.blue}
/>
<Button
palette="primary"
condition={ value <= 5 ? props1 : props2 }
className={style.blue}
/>
<Button
palette="primary"
className={style.blue}
condition={ value => 5 ? props1 : props2 }
/>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)