import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Button[^>]*[\\n\\s]+className[^>]*>";
final String string = "<Button className={style.red} />\n\n"
+ "<Button className={style.red}> </Button>\n\n"
+ "<Button\n"
+ " palette=\"primary\" \n"
+ " className={style.blue} \n"
+ "/>\n\n"
+ "<Button\n"
+ " palette=\"primary\"\n"
+ "/>\n\n"
+ "<Button\n"
+ " palette=\"primary\" \n"
+ " className={style.blue} \n"
+ ">\n"
+ "</Button>\n\n"
+ "<Button\n"
+ " palette=\"primary\" \n"
+ " condition={ value => 5 ? props1 : props2 }\n"
+ " className={style.blue} \n"
+ "/>\n\n"
+ "<Button\n"
+ " palette=\"primary\" \n"
+ " condition={ value <= 5 ? props1 : props2 }\n"
+ " className={style.blue} \n"
+ "/>\n\n"
+ "<Button\n"
+ " palette=\"primary\" \n"
+ " className={style.blue} \n"
+ " condition={ value => 5 ? props1 : props2 }\n"
+ "/>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}