re = /<Button[^>]*[\n\s]+className[^>]*>/m
str = '<Button className={style.red} />
<Button className={style.red}> </Button>
<Button
palette="primary"
className={style.blue}
/>
<Button
palette="primary"
/>
<Button
palette="primary"
className={style.blue}
>
</Button>
<Button
palette="primary"
condition={ value => 5 ? props1 : props2 }
className={style.blue}
/>
<Button
palette="primary"
condition={ value <= 5 ? props1 : props2 }
className={style.blue}
/>
<Button
palette="primary"
className={style.blue}
condition={ value => 5 ? props1 : props2 }
/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end