#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?=.*[a-z])(?!.*[<>\\'"])[\x00-\x7F]{5,22}$"
Local $sString = "ылшщъьбe" & @CRLF & _
"12345678901234567s9012" & @CRLF & _
"12345678901234567s90123" & @CRLF & _
"12345678901234567s901Я" & @CRLF & _
"abcdeabcdeab"abcde" & @CRLF & _
"abcdeabcdeab'abcde" & @CRLF & _
"abcdeabcdeab\abcde" & @CRLF & _
"abcdeabcdeab>abcde" & @CRLF & _
"abcdeabcdeab<abcde" & @CRLF & _
"abcdeabcdeab"abcde" & @CRLF & _
"abcdeabcdeababcde" & @CRLF & _
"12345678901234567s9012" & @CRLF & _
"12345678901234567s90123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")